How to

Configure Inter-VLAN Routing

In this <How to> lesson we will see how to configure Inter-VLAN Routing on a Router. These settings includes :

  1. Create Vlan
  2. Configure an interface as trunk
  3. Configure sub-interface on a Router

1.Create vlans on S1

S1(config)# vlan 10

S1(config-vlan)# vlan 30

S1(config-vlan)#exit

2. Configure S1’s interface F0/5 as trunk

S1(config)# interface f0/5

S1(config-if)# switchport mode trunk

3.Configure sub-interfaces on R1

R1(config)# interface g0/0.10

R1(config-subif)# encapsulation dot1q 10

R1(config-subif)# ip address 172.17.10.1 255.255.255.0

R1(config-subif)# interface g0/0.30

R1(config-subif)# encapsulation dot1q 30

R1(config-subif)# ip address 172.17.30.1 255.255.255.0

R1(config)# interface g0/0

R1(config-if)# no shutdown